I get this error quite a lot when trying to deploy an Android APK to an emulator.

Device supports x86_64, x86, but APK only support , all, armeabi-v7a

The good thing is that it is actually a very easy thing to fix.

While doing development you can simply change the Build Variant target.

How do you do that?

Click “View” -> “Tool Window” -> “Build Variants

Notice that ARM is currently selected and most of the time you will want x86 to be the build target if you are deploying to a emulator.

Select the “x86Debug” from the dropdown list. Gradle will automatically resync itself and then you can repeat your “Run” task to deploy to your emulator.

Note that you will probably want to change this back to it’s original setting before deploying to a device again.

Categories: Content

Leave a Reply

Your email address will not be published. Required fields are marked *